const regex = /^(\d*(?:\.\d+)?)[\.\d]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d*(?:\\.\\d+)?)[\\.\\d]*$', 'gm')
const str = `0.2
2.2
2.0
.2
2.2.
0.2.
2.2.2.2.2
0.2.2.2
.22.2.2.2
2222.22
2.
222.
123.12a`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);