use strict;
my $str = '0.2
2.2
2.0
.2
2.2.
0.2.
2.2.2.2.2
0.2.2.2
.22.2.2.2
2222.22
2.
222.
123.12a';
my $regex = qr/^(\d*(?:\.\d+)?)[\.\d]*$/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";