package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d*(?:\.\d+)?)[\.\d]*$`)
var str = `0.2
2.2
2.0
.2
2.2.
0.2.
2.2.2.2.2
0.2.2.2
.22.2.2.2
2222.22
2.
222.
123.12a`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}