// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\d*(?:\.\d+)?)[\.\d]*$").unwrap();
let string = "0.2
2.2
2.0
.2
2.2.
0.2.
2.2.2.2.2
0.2.2.2
.22.2.2.2
2222.22
2.
222.
123.12a";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}