re = /^(\d*(?:\.\d+)?)[\.\d]*$/m
str = '0.2
2.2
2.0
.2
2.2.
0.2.
2.2.2.2.2
0.2.2.2
.22.2.2.2
2222.22
2.
222.
123.12a'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result