#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!Account n.:\s\d{3}.)(?<!(\d|\/))\d{7}(?!.*has been received and is being reviewed by)(?!.*has been solved. To reopen)(?!\w)"
Local $sString = "Account n.: 243-479688.71J" & @CRLF & _
"Your request (443760) has been solved. To reopen this request, reply to this email.." & @CRLF & _
"Article DOI: 10.3389/fchem.2020.500600" & @CRLF & _
"Article DOI: 10.3389/fchem.2020.5006001" & @CRLF & _
"Article DOI: 10.3389/fchem.2020.50060"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")