import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!Account n.:\\s\\d{3}.)(?<!(\\d|\\/))\\d{7}(?!.*has been received and is being reviewed by)(?!.*has been solved. To reopen)(?!\\w)";
final String string = "Account n.: 243-479688.71J\n"
+ "Your request (443760) has been solved. To reopen this request, reply to this email..\n"
+ "Article DOI: 10.3389/fchem.2020.500600\n"
+ "Article DOI: 10.3389/fchem.2020.5006001\n"
+ "Article DOI: 10.3389/fchem.2020.50060";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}