import re
regex = re.compile(r"(?<!Account n.:\s\d{3}.)(?<!(\d|\/))\d{7}(?!.*has been received and is being reviewed by)(?!.*has been solved. To reopen)(?!\w)", flags=re.MULTILINE)
test_str = ("Account n.: 243-479688.71J\n"
"Your request (443760) has been solved. To reopen this request, reply to this email..\n"
"Article DOI: 10.3389/fchem.2020.500600\n"
"Article DOI: 10.3389/fchem.2020.5006001\n"
"Article DOI: 10.3389/fchem.2020.50060")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")