import Foundation
let pattern = #"(?<!Account n.:\s\d{3}.)(?<!(\d|\/))\d{7}(?!.*has been received and is being reviewed by)(?!.*has been solved. To reopen)(?!\w)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Account n.: 243-479688.71J
Your request (443760) has been solved. To reopen this request, reply to this email..
Article DOI: 10.3389/fchem.2020.500600
Article DOI: 10.3389/fchem.2020.5006001
Article DOI: 10.3389/fchem.2020.50060
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)