using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!Account n.:\s\d{3}.)(?<!(\d|\/))\d{7}(?!.*has been received and is being reviewed by)(?!.*has been solved. To reopen)(?!\w)";
string input = @"Account n.: 243-479688.71J
Your request (443760) has been solved. To reopen this request, reply to this email..
Article DOI: 10.3389/fchem.2020.500600
Article DOI: 10.3389/fchem.2020.5006001
Article DOI: 10.3389/fchem.2020.50060";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}