use strict;
my $str = 'Account n.: 243-479688.71J
Your request (443760) has been solved. To reopen this request, reply to this email..
Article DOI: 10.3389/fchem.2020.500600
Article DOI: 10.3389/fchem.2020.5006001
Article DOI: 10.3389/fchem.2020.50060';
my $regex = qr/(?<!Account n.:\s\d{3}.)(?<!(\d|\/))\d{7}(?!.*has been received and is being reviewed by)(?!.*has been solved. To reopen)(?!\w)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}