# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?=.*status[:=](\S+)|)(?=.*type[:=](\S+)|)(?:.*?title[:=])?(?|"([^"\n]+)"|((?:(?!\s?(?:type|status)).)+))[^"\n]*$//gm;t' <<< "stack overflow
\"stackoverflow\"
title=\"stack overflow\"
type:image title=stack overflow
stackoverflow type:image
status:closed type:image title:stack overflow
title=\"stack overflow\" type:joy
title:you should totally drop regex and try jquery type:joke"