re = /^(?=.*status[:=](\S+)|)(?=.*type[:=](\S+)|)(?:.*?title[:=])?(?|"([^"\n]+)"|((?:(?!\s?(?:type|status)).)+))[^"\n]*$/m
str = 'stack overflow
"stackoverflow"
title="stack overflow"
type:image title=stack overflow
stackoverflow type:image
status:closed type:image title:stack overflow
title="stack overflow" type:joy
title:you should totally drop regex and try jquery type:joke'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result