$re = '/^(?=.*status[:=](\S+)|)(?=.*type[:=](\S+)|)(?:.*?title[:=])?(?|"([^"\n]+)"|((?:(?!\s?(?:type|status)).)+))[^"\n]*$/m';
$str = 'stack overflow
"stackoverflow"
title="stack overflow"
type:image title=stack overflow
stackoverflow type:image
status:closed type:image title:stack overflow
title="stack overflow" type:joy
title:you should totally drop regex and try jquery type:joke';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;