import Foundation
let pattern = #"^(?=.*status[:=](\S+)|)(?=.*type[:=](\S+)|)(?:.*?title[:=])?(?|"([^"\n]+)"|((?:(?!\s?(?:type|status)).)+))[^"\n]*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
stack overflow
"stackoverflow"
title="stack overflow"
type:image title=stack overflow
stackoverflow type:image
status:closed type:image title:stack overflow
title="stack overflow" type:joy
title:you should totally drop regex and try jquery type:joke
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)