#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?=.*status[:=](\S+)|)(?=.*type[:=](\S+)|)(?:.*?title[:=])?(?|"([^"\n]+)"|((?:(?!\s?(?:type|status)).)+))[^"\n]*$"
Local $sString = "stack overflow" & @CRLF & _
""stackoverflow"" & @CRLF & _
"title="stack overflow"" & @CRLF & _
"type:image title=stack overflow" & @CRLF & _
"stackoverflow type:image" & @CRLF & _
"status:closed type:image title:stack overflow" & @CRLF & _
"title="stack overflow" type:joy" & @CRLF & _
"title:you should totally drop regex and try jquery type:joke"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)