use strict;
my $str = 'stack overflow
"stackoverflow"
title="stack overflow"
type:image title=stack overflow
stackoverflow type:image
status:closed type:image title:stack overflow
title="stack overflow" type:joy
title:you should totally drop regex and try jquery type:joke';
my $regex = qr/^(?=.*status[:=](\S+)|)(?=.*type[:=](\S+)|)(?:.*?title[:=])?(?|"([^"\n]+)"|((?:(?!\s?(?:type|status)).)+))[^"\n]*$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";