using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*status[:=](\S+)|)(?=.*type[:=](\S+)|)(?:.*?title[:=])?(?|""([^""\n]+)""|((?:(?!\s?(?:type|status)).)+))[^""\n]*$";
string substitution = @"";
string input = @"stack overflow
""stackoverflow""
title=""stack overflow""
type:image title=stack overflow
stackoverflow type:image
status:closed type:image title:stack overflow
title=""stack overflow"" type:joy
title:you should totally drop regex and try jquery type:joke";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}