# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\<img src=.*\\/storyimages\\/.*?>//g;t' <<< "<br><img src=\"/storyimages/myimage.jpg\" align=\"right\" WIDTH=\"105\" HEIGHT=\"131\"><b>(CNS) </b>Lorem ipsum dolor..."