import Foundation
let pattern = #"\<img src=.*\/storyimages\/.*?>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<br><img src="/storyimages/myimage.jpg" align="right" WIDTH="105" HEIGHT="131"><b>(CNS) </b>Lorem ipsum dolor..."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)