re = /\<img src=.*\/storyimages\/.*?>/
str = '<br><img src="/storyimages/myimage.jpg" align="right" WIDTH="105" HEIGHT="131"><b>(CNS) </b>Lorem ipsum dolor...'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result