const regex = /\<img src=.*\/storyimages\/.*?>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\<img src=.*\\\/storyimages\\\/.*?>', 'g')
const str = `<br><img src="/storyimages/myimage.jpg" align="right" WIDTH="105" HEIGHT="131"><b>(CNS) </b>Lorem ipsum dolor...`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);