#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?:https?:\/\/)?www\.ex[ma][ma]ple\.com\/tp\/\S+\d+)"
Local $sString = "" & @CRLF & _
" http://www.exmaple.com/tp/123" & @CRLF & _
" www.exmaple.com/tp/abc/123" & @CRLF & _
" https://www.exmaple.com/tp/123" & @CRLF & _
"" & @CRLF & _
" http://www.example.com/tp/123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")