import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:https?:\\/\\/)?www\\.ex[ma][ma]ple\\.com\\/tp\\/\\S+\\d+)";
final String string = "\n"
+ " http://www.exmaple.com/tp/123\n"
+ " www.exmaple.com/tp/abc/123\n"
+ " https://www.exmaple.com/tp/123\n\n"
+ " http://www.example.com/tp/123";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}