package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((?:https?:\/\/)?www\.ex[ma][ma]ple\.com\/tp\/\S+\d+)`)
var str = `
http://www.exmaple.com/tp/123
www.exmaple.com/tp/abc/123
https://www.exmaple.com/tp/123
http://www.example.com/tp/123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}