using System;
using System.Text.RegularExpressions;
public class Example
{
    public static void Main()
    {
        string pattern = @"((?:https?:\/\/)?www\.ex[ma][ma]ple\.com\/tp\/\S+\d+)";
        string input = @"
    http://www.exmaple.com/tp/123
    www.exmaple.com/tp/abc/123
    https://www.exmaple.com/tp/123
 http://www.example.com/tp/123";
        RegexOptions options = RegexOptions.Multiline;
        
        foreach (Match m in Regex.Matches(input, pattern, options))
        {
            Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
        }
    }
}