re = /((?:https?:\/\/)?www\.ex[ma][ma]ple\.com\/tp\/\S+\d+)/m
str = '
    http://www.exmaple.com/tp/123
    www.exmaple.com/tp/abc/123
    https://www.exmaple.com/tp/123
 http://www.example.com/tp/123'
# Print the match result
str.scan(re) do |match|
    puts match.to_s
end