$re = '/((?:https?:\/\/)?www\.ex[ma][ma]ple\.com\/tp\/\S+\d+)/m';
$str = '
http://www.exmaple.com/tp/123
www.exmaple.com/tp/abc/123
https://www.exmaple.com/tp/123
http://www.example.com/tp/123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);