#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ".{2}\@.{2}\K|\..*(*SKIP)(*F)|.(?=.*\.)"
Local $sString = "trabc@abtrec.com.lo" & @CRLF & _
"demomail@demodomain.com"
Local $sSubst = "*"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)