re = /.{2}\@.{2}\K|\..*(*SKIP)(*F)|.(?=.*\.)/
str = 'trabc@abtrec.com.lo
demomail@demodomain.com'
subst = '*'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result