import Foundation
let pattern = #".{2}\@.{2}\K|\..*(*SKIP)(*F)|.(?=.*\.)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
trabc@abtrec.com.lo
demomail@demodomain.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"*"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)