const regex = /.{2}\@.{2}\K|\..*(*SKIP)(*F)|.(?=.*\.)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.{2}\\@.{2}\\K|\\..*(*SKIP)(*F)|.(?=.*\\.)', 'g')
const str = `trabc@abtrec.com.lo
demomail@demodomain.com`;
const subst = `*`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);