use strict;
my $str = 'trabc@abtrec.com.lo
demomail@demodomain.com';
my $regex = qr/.{2}\@.{2}\K|\..*(*SKIP)(*F)|.(?=.*\.)/p;
my $subst = '*';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";