using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".{2}\@.{2}\K|\..*(*SKIP)(*F)|.(?=.*\.)";
string substitution = @"*";
string input = @"trabc@abtrec.com.lo
demomail@demodomain.com";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}