$re = '/.{2}\@.{2}\K|\..*(*SKIP)(*F)|.(?=.*\.)/';
$str = 'trabc@abtrec.com.lo
demomail@demodomain.com';
$subst = "*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;