# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\w)\1\1\K\1+//g;t' <<< "Hellooaaaoooo Louis, waaaat's up pal"