use strict;
my $str = 'Hellooaaaoooo Louis, waaaat\'s up pal';
my $regex = qr/(\w)\1\1\K\1+/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";