import Foundation
let pattern = #"(\w)\1\1\K\1+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Hellooaaaoooo Louis, waaaat's up pal"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)