using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w)\1\1\K\1+";
string substitution = @"";
string input = @"Hellooaaaoooo Louis, waaaat's up pal";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}