re = /(\w)\1\1\K\1+/
str = 'Hellooaaaoooo Louis, waaaat\'s up pal'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result