using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*[Cc]:(?:(?:\/|\\{1,2})\w+)+\.\w+";
string input = @"C:\Users\esteban\Desktop\Java_file_testing\file3.txt
C:/Users/esteban/Desktop/Java_file_testing/file3.txt
C://Users//esteban//Desktop//Java_file_testing//file3.txt
c:\\Users\\esteban\\Desktop\\Java_file_testing\\file3.txt
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}