package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s*[Cc]:(?:(?:\/|\\{1,2})\w+)+\.\w+`)
var str = `C:\Users\esteban\Desktop\Java_file_testing\file3.txt
C:/Users/esteban/Desktop/Java_file_testing/file3.txt
C://Users//esteban//Desktop//Java_file_testing//file3.txt
c:\\Users\\esteban\\Desktop\\Java_file_testing\\file3.txt
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}