import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*[Cc]:(?:(?:\\/|\\\\{1,2})\\w+)+\\.\\w+";
final String string = "C:\\Users\\esteban\\Desktop\\Java_file_testing\\file3.txt\n"
+ "C:/Users/esteban/Desktop/Java_file_testing/file3.txt\n"
+ "C://Users//esteban//Desktop//Java_file_testing//file3.txt\n"
+ "c:\\\\Users\\\\esteban\\\\Desktop\\\\Java_file_testing\\\\file3.txt\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}