// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\s*[Cc]:(?:(?:\/|\\{1,2})\w+)+\.\w+").unwrap();
let string = "C:\\Users\\esteban\\Desktop\\Java_file_testing\\file3.txt
C:/Users/esteban/Desktop/Java_file_testing/file3.txt
C://Users//esteban//Desktop//Java_file_testing//file3.txt
c:\\\\Users\\\\esteban\\\\Desktop\\\\Java_file_testing\\\\file3.txt
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}