const regex = /\s*[Cc]:(?:(?:\/|\\{1,2})\w+)+\.\w+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*[Cc]:(?:(?:\\\/|\\\\{1,2})\\w+)+\\.\\w+', 'g')
const str = `C:\\Users\\esteban\\Desktop\\Java_file_testing\\file3.txt
C:/Users/esteban/Desktop/Java_file_testing/file3.txt
C://Users//esteban//Desktop//Java_file_testing//file3.txt
c:\\\\Users\\\\esteban\\\\Desktop\\\\Java_file_testing\\\\file3.txt
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}