re = /\s*[Cc]:(?:(?:\/|\\{1,2})\w+)+\.\w+/
str = 'C:\\Users\\esteban\\Desktop\\Java_file_testing\\file3.txt
C:/Users/esteban/Desktop/Java_file_testing/file3.txt
C://Users//esteban//Desktop//Java_file_testing//file3.txt
c:\\\\Users\\\\esteban\\\\Desktop\\\\Java_file_testing\\\\file3.txt
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end