using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/\*[^*]*\*+([^\/*][^*]*\*+)*\/(*SKIP)(*F)|^(\w+)\s*=\s*(\w+)";
string input = @"/*
anything description
*/
Data1 = value1;
Other_Data = Other_Value;
/*
my other description
*/
Anything = Any_Answer;
/*
this is description and must not detect
Description_Data = Any_Value;
*/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}