import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/\\*[^*]*\\*+([^\\/*][^*]*\\*+)*\\/(*SKIP)(*F)|^(\\w+)\\s*=\\s*(\\w+)";
final String string = "/*\n"
+ "anything description\n"
+ "*/\n\n"
+ "Data1 = value1;\n\n"
+ "Other_Data = Other_Value;\n\n"
+ "/*\n"
+ "my other description\n"
+ "*/\n\n"
+ "Anything = Any_Answer;\n\n"
+ "/*\n\n"
+ "this is description and must not detect\n\n"
+ "Description_Data = Any_Value;\n\n"
+ "*/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}