// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\/\*[^*]*\*+([^\/*][^*]*\*+)*\/(*SKIP)(*F)|^(\w+)\s*=\s*(\w+)").unwrap();
let string = "/*
anything description
*/
Data1 = value1;
Other_Data = Other_Value;
/*
my other description
*/
Anything = Any_Answer;
/*
this is description and must not detect
Description_Data = Any_Value;
*/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}