import Foundation
let pattern = #"\/\*[^*]*\*+([^\/*][^*]*\*+)*\/(*SKIP)(*F)|^(\w+)\s*=\s*(\w+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/*
anything description
*/
Data1 = value1;
Other_Data = Other_Value;
/*
my other description
*/
Anything = Any_Answer;
/*
this is description and must not detect
Description_Data = Any_Value;
*/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)